Exercice 12/14

  • Dans la section <body>, ouvrez une balise <a>.

  • Ajoutez l'adresse du site internet de votre choix après href (comme dans <a href="https://3wa.fr">.

  • Insérez une nouvelle balise <img> entre vos balises ouvrante <a> et fermante </a>. N'oubliez pas l'attribut src !

  • Fermez votre balise </a>

Leçon 12/14

Bien entendu, il n'est pas interdit de rendre une image cliquable, comme vous l'avez fait pour le texte.

Il suffit pour cela de mettre votre balise <img> entre les 2 balises <a> comme ceci :

<a href="https://3wa.fr/">
    <img src="https://people.rit.edu/meb5367/105/project02/images/berners_lee_3.jpg" />
</a>

En cliquant sur la photo du génial inventeur, vous serez ainsi redirigé vers un site ... tout aussi génial. C'est cohérent. On appelle cela l'imbrication de balises HTML mais ce n'est pas nouveau : c'est bien ce que vous avez fait en mettant <body> à l'intérieur de <html></html> ou encore votre code à l'intérieur de <body></body>, n'est-ce pas ?

Vérifiez que vous avez bien inséré entre guillemets une adresse web complète, de la forme "http://www.google.fr" !

Votre code doit ressembler à cela :

<a href="URL du LIEN">
    <img src="URL de l'IMAGE" />
</a>

Essayez de transformer une image en lien vers "https://3wa.fr" puis cliquez dessus pour voir le lien en action. Si vous utilisez une autre URL, il est possible que cela ne fonctionne pas à cause des règles de sécurité du site !

Commentaires les mieux notés

  • francois.boisselier-31

    Bonjour je ne comprends pas mon erreur, pouvez-vous m'aider?

  • elia.bald-14

    ils me disent que l'image n'est pas insérée au bon endroit

  • camille.alphe

    Merci! je vais essayer.

  • camille.alphe

    Merci en vrai je m'étais compliqué la vie pour rien.......:-)

128 Commentaires

  • camille.alphe

    camille.alphe

    Merci! je vais essayer.

    le 03/11/2016 à 23h56

  • camille.alphe

    camille.alphe

    Merci en vrai je m'étais compliqué la vie pour rien.......:-)

    le 04/11/2016 à 15h26

  • contactruddy

    contactruddy

    Bonjour, Je rencontre un message d'erreur m'indiquant qu'il faut vérifier l'attribut src de la balise img pourtant mon code a l'air bon, non? <!DOCTYPE html> <html> <head> <title>ok</title> </head> <body> <img src="https://people.rit.edu/meb5367/105/project02/images/berners_lee_3.jpg" /> <a href="https://fr.yahoo.com/"><img src="https://encrypted-tbn3.gstatic.com/images?q=tbn:ANd9GcQJvUhmpXYMkHzJX4bXckvbSsHi1kwB0FRiW9fb3UzO_8vKFgOhFWE7Gxk" /></a> </body> </html>

    le 21/10/2016 à 12h45

  • meriam

    meriam Administrateur

    ne touchez la première image, il faut ajouter une deuxième.

    le 12/03/2019 à 15h42

  • mram

    mram Administrateur

    Simplifiez votre code, il faut juste un couple de balise <body> ... </body> dans lequel se trouve tout votre code HTML. Ensuite mettez dedans juste une balise <img> et en dessous un lien <a> qui contient une balise <img>.

    le 02/11/2016 à 21h09

  • contactruddy

    contactruddy

    c bon jai trouver bonne journee

    le 21/10/2016 à 12h56

  • camille.alphe

    camille.alphe

    Vous n'avez pas ajouté de balise <a> dans le body je suis perdu la.

    le 01/11/2016 à 23h49

  • nonaud

    nonaud

    Alors pour moi ça marche et ça valide, mais il faut faire clique droit "ouvrir dans un nouvel onglet", c'est normal ?

    le 31/01/2017 à 12h02

  • sophie.fega

    sophie.fega

    <!DOCTYPE html> <html> <head> <title>training</title> </head> <body> <a href="http://www.animaljam.com/welcome"> <img src="https://commons.wikimedia.org/wiki/File:Animal_diversity.png?uselang=fr"/> </a> </body> </html> juste non ? pourquoi me demande t on de vérifier l'attribut src?

    le 26/03/2016 à 23h38

  • sophie.fega

    sophie.fega

    pourquoi mes résultats ne sont-ils pas visibles ??

    le 26/03/2016 à 23h43

  • mram

    mram Administrateur

    Bonjour, pour le message sur l'attribut src, essayez de choisir une url d'image plus simple. Vos résultats sont normalement visibles si vous mettez une url d'image correcte.

    le 29/03/2016 à 01h42

  • AW

    AW

    Image affichée, Clique sur l'image et grand blanc ! Chrome sur Mac

    le 09/06/2016 à 18h14

  • mram

    mram Administrateur

    Bonjour, tant que vous pouvez valider l'exercice, c'est bon. J'ai testé votre code avec un clic droit sur votre image (lien delcaflor) et ça fonctionne parfaitement.

    le 09/06/2016 à 23h47

  • evemariec

    evemariec

    Le message d'erreur suivant s'affiche : insérer l'attribut de l'image src. Je l'ai pourtant fait, l'exercice n'est pas validé.

    le 10/12/2016 à 20h32

  • pizzutoandrea3

    pizzutoandrea3

    bonjour j'ai code : <!DOCTYPE html><html><head><title>Andy mon chien</title> </head><body><a href="https://andreapizzuto.jimdo.com">Digital Art !</a> <img src="https://scontent-cdg2-1.xx.fbcdn.net/v/t1.0-9/188205_1885547346712_2181872_n.jpg?oh=6c28dbdbaf428b8d5720fd0cb560e08e&amp;oe=59553E81"/> </body> </html> eror.. Bonjour, Je rencontre un message d'erreur m'indiquant qu'il faut vérifier l'attribut src dans img?

    le 21/03/2017 à 15h24

  • mram

    mram Administrateur

    Oui en effet, mais il faut mettre l'image <img /> à l'intérieur d'un lien <a>...</a>.

    le 13/12/2016 à 10h59

  • antony.morais

    antony.morais

    Bonjour, l'image ne s affiche pas erreur 404 quand je rentre cette URL: "https://people.rit.edu/meb5367/105/project02/images/berners_lee_3.jpg" dans le navigateur... je l ai donc remplacée par celle-ci: "https://people.rit.edu/japnce/payne/bernerslee/images/timW94H118.gif"

    le 10/01/2017 à 15h02

  • mram

    mram Administrateur

    Il est aussi possible de le valider sans faire cela...

    le 02/02/2017 à 23h55

  • mram

    mram Administrateur

    Oui, car le lien que vous avez mis n'est pas au bon format. Essayez avec un lien plus simple qui se termine par .jpg, .png, .gif ...

    le 24/03/2017 à 10h26

  • mram

    mram Administrateur

    Ok, tant que vous pouvez valider l'exercice, vous pouvez mettre l'image de votre choix.

    le 11/01/2017 à 19h06

  • vfaiola-21

    vfaiola-21

    bonjour, je suis au bout de ma vie ;-) je ne vois pas où est l'erreur

    le 21/06/2018 à 15h18

  • mram

    mram Administrateur

    Bonjour, votre code est correct, ne tenez pas compte de l'erreur ici.

    le 24/06/2018 à 06h43

  • fchakroun-24

    fchakroun-24

    il dit que jaioublié href dans la balise <a>

    le 24/07/2018 à 22h24

  • mram

    mram Administrateur

    C'est à cause du signe > qui n'est pas au bon endroit.

    le 01/08/2018 à 05h32

  • lsamy2409

    lsamy2409

    je me demande ou est l'erreur chez moi!!!

    le 11/03/2018 à 12h51

  • mram

    mram Administrateur

    Bonjour, votre code est correct. Ne tenez pas compte du message ici.

    le 12/03/2018 à 00h25

  • thibaut.debaere-67

    thibaut.debaere-67

    Bonjour, pouvez vous m'aider ? Il me demande de corriger la balise img qui ne semble pas dans la balise body, alors que si... non ?

    le 19/12/2018 à 14h24

  • meriam

    meriam Administrateur

    Il faut ajouter une deuxième image et rendez la cliquable.

    le 19/12/2018 à 15h46

  • lot.khom.pro-94

    lot.khom.pro-94

    Bonjour, il me semble que j'ai bien placé la balise IMG à l'intérieur de celle de Body. D'ailleurs lorsque je clique sur l'image, cela me renvoie bien sur le site. Je ne vois pas où est se situe mon erreur. Pouvez vous me confirmer ?

    le 13/12/2018 à 07h49

  • meriam

    meriam Administrateur

    il faut laisser l'image initiale telle qu'elle est puis ajoutez une deuxième image et rendez la cliquable avec la balise a (lisez bien l'énoncé il faut insérer une deuxième image).

    le 13/12/2018 à 14h25

  • yaneeck

    yaneeck

    Je ne comprend pas, l'attribut href de ma balise <a> est pourtant présent...

    le 04/09/2017 à 08h38

  • mram

    mram Administrateur

    Bonjour, vous avez oubliez le chevron > pour fermer la balise img.

    le 06/09/2017 à 11h14

  • soniakwm-7

    soniakwm-7

    mais un message d'erreur m'indimais le message d'erreur m'indique si la balise omg se trouve bien dans body .. je bloque du coup merci

    le 22/11/2018 à 19h45

  • meriam

    meriam Administrateur

    Il faut pas toucher la première image initiale, il faut ajouter une deuxième image avec la balise img et rendez la cliquable (juste aprés l'image initiale).

    le 23/11/2018 à 09h45

  • Kyhla

    Kyhla

    Bonjour, tout s'affiche comme il faut, pourtant on me demande de "Vérifier l'attribut src" ... j'ai beau chercher, je ne vois pas où est l'erreur... <!DOCTYPE html> <html> <head> <title>Japon</title> </head> <body> <a href="https://fr.wikipedia.org/wiki/Japon"> <img src="https://images.salaun-holidays.com/(Image)-image-Japon-25-it_70546755-not-found-09032017.jpg"/> </a> </body> </html>

    le 12/12/2017 à 14h50

  • mram

    mram Administrateur

    Bonjour, je pense que ça vient des parenthèses dans l'URL de l'image .

    le 14/12/2017 à 21h26

  • belespoir38

    belespoir38

    Bonjour, l'excercice est validé, mais à la place de l'image, il y a une croix. Est-ce normal ?

    le 05/09/2017 à 20h46

  • mram

    mram Administrateur

    Bonjour, parce que le lien vers l'image n'était pas correct.

    le 06/09/2017 à 11h50

  • ronald.rukund-23

    ronald.rukund-23

    j'ai le même problème 2 fois , pouvais vous me dire ou est ce que j'ai eu faut s'il vous plait

    le 21/12/2018 à 14h35

  • meriam

    meriam Administrateur

    Bonjour, vous devez ajouter une deuxième image aprés la première et rendez cette deuxième cliquable.(relisez l'énoncé Insérez une nouvelle balise < img> entre vos balises ouvrante < a> et fermante < /a>.

    le 21/12/2018 à 15h18

  • fbeaubrundiant-99

    fbeaubrundiant-99

    bonjour, cela me dit qu'il manque la balise src alors que je l'ai..

    le 18/03/2018 à 17h19

  • mram

    mram Administrateur

    Bonjour, on vous demande de mettre une image dans un lien : aucune de vos deux images ne sont dans le lien. Relisez les instructions.

    le 19/03/2018 à 05h19

  • dimandja-jonathan-36

    dimandja-jonathan-36

    bonjour ca me met qu'il manque l'attribut herf hors qu'il es présent

    le 07/02/2018 à 16h29

  • mram

    mram Administrateur

    Bonjour, vous avez oublié de fermer la balise de la première image ligne 7.

    le 08/02/2018 à 14h27

  • boras.b-46

    boras.b-46

    Je ne comprends pas j'ai mis href dans <a>????

    le 14/08/2018 à 16h00

  • mram

    mram Administrateur

    Non l'attribut href doit être dans la balise "a" ouvrante :

    > < a href="...">Texte< /a>

    le 17/08/2018 à 06h40

  • christopher62220-84

    christopher62220-84

    Bonjour Erreur(s) : Vous avez oublié l'attribut src de votre balise <img> se que c'est normal vu que tout et bon ?

    le 28/06/2018 à 16h24

  • mram

    mram Administrateur

    Bonjour, non tout n'était pas bon, l'attirbut ligne 10 était mal placé (après la balise au lieu d'être dedans).

    le 05/07/2018 à 04h05

  • arnaud.delaportaliere

    arnaud.delaportaliere

    bonjour, je ne comprends pas pourquoi mon code n'est pas bon

    le 21/11/2017 à 18h15

  • mram

    mram Administrateur

    Bonjour, votre code est correct. Quelle erreur avez-vous ?

    le 26/11/2017 à 19h06

  • laurentbanco-23

    laurentbanco-23

    Bonjour, je ne comprend pas mon erreur, j'ai pourtant bien inséré la balise <a>

    le 27/04/2018 à 21h12

  • mram

    mram Administrateur

    Bonjour, votre code est correct. Ne tenez pas compte du message ici.

    le 29/04/2018 à 04h01

  • osinchuk28-100

    osinchuk28-100

    <!DOCTYPE html> <html> <head> <title>Mon site</title> </head> <body> <a href="https://3wa.fr"><img scr="https://upload.wikimedia.org/wikipedia/commons/thumb/a/a5/Robert_Cailliau_On_Desk.jpg/220px-Robert_Cailliau_On_Desk.jpg" /></a> </body> </html>

    le 18/10/2018 à 10h19

  • meriam

    meriam Administrateur

    l'attribut de la balise image est src et scr ;

    le 18/10/2018 à 12h14

  • vadim.olivan-96

    vadim.olivan-96

    "Vous avez oublié l'attribut src de votre balise <img>" C'est vous qui l'avez mise espèce de correcteur !

    le 28/01/2018 à 10h11

  • mram

    mram Administrateur

    Bonjour, c'est parce que vous aviez mis l'attribut "src" au lien "a" alors que lui possède l'attribut "href" .

    le 30/01/2018 à 18h53

  • vadim.olivan-96

    vadim.olivan-96

    Et les images ne s'affichent toujours pas

    le 28/01/2018 à 10h13

  • mram

    mram Administrateur

    Normal, l'image que vous avez choisi n'est plus à l'adresse indiquée à priori.

    le 30/01/2018 à 18h54

  • ferreiracerqueirac-14

    ferreiracerqueirac-14

    Bonjour, je trouve pas le erreur. Message: "Erreur interne:..."

    le 17/12/2018 à 10h57

  • meriam

    meriam Administrateur

    bonjour, problème au niveau de la source de votre image (essayer une source valide ), de meme pour l'adresse de l'attribut href (ajoutez par exemple l'adresse href="https://3wa.fr").

    le 17/12/2018 à 11h14

  • laetitiadiouris-89

    laetitiadiouris-89

    bonjours pour moi on me dit que j'ai oublier la balises herf alors que je l'ai donc je ne comprend pas

    le 30/01/2018 à 13h28

  • mram

    mram Administrateur

    Bonjour, votre code est correct, ne tenez pas compte de l'erreur ici.

    le 30/01/2018 à 19h11

  • melissa.latieule-84

    melissa.latieule-84

    Bonjour, j'ai une erreur qui me dit: "Avez-vous bien placé la balise <img> à l'intérieur de la balise <body> ?" alors que dans mon code il est bien la...

    le 27/11/2018 à 21h15

  • meriam

    meriam Administrateur

    Il faut pas toucher la balise image initiale, ajouter une deuxième et rendez la cliquable .

    le 28/11/2018 à 01h29

  • patrick.dumas60-79

    patrick.dumas60-79

    Erreur avez vous bien placé la balise <img> à l'interieur de la balise <body> alors que mon code à l'air correct <!DOCTYPE html> <html> <head> <title></title> </head> <body> <a href="http://google.fr" > <img src="https://imge.com/wp-content/uploads/2016/05/EarphonesMac.png" /> </a> </body> </html>

    le 12/12/2018 à 12h00

  • meriam

    meriam Administrateur

    Vous avez placé deux images à l'intérieur de la balise a, il faut mettre une seule. la première image d'origine doit etre non cliquable.

    le 12/12/2018 à 12h25

  • PDM-85

    PDM-85

    merci :-)

    le 28/11/2018 à 20h26

  • caroline_guillen-60

    caroline_guillen-60

    Non mais des heures que je cherche et mon seul soucis c'est que je suis revenue à la ligne entre le site internet et l'image ! Sérieux c'est à hurler. Bon étape suivante !

    le 28/02/2019 à 14h44

  • melissa.latieule-84

    melissa.latieule-84

    bonjour, j'ai réussi, je pense que j'ai du mal comprendre la consigne. Merci!

    le 28/11/2018 à 10h57